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Symantec Endpoint Protection Manager 11.x communication troubleshooting

Question/Issue:
Symantec Endpoint Protection Manager is experiencing communication issues by logging errors or displaying HTTP error codes.

Symptoms:


Cause:
There are many possible causes for this problem. Be sure to read through all of the possible causes and solutions listed below.


Solution:
Compatibility Assessment
Please refer to the following document to ensure that you meet the supported configuration:

"System requirements for Symantec Endpoint Protection 11 and Symantec Network Access Control 11" at:
http://service1.symantec.com/SUPPORT/ent-security.nsf/docid/2007082112580548


Operating System Assessment
Microsoft Windows XP Professional Edition and Windows 2000 Professional Edition are limited to a maximum of ten (10) concurrent connections. Please refer to Microsoft's End User Licensing Agreement (EULA) or Microsoft's Knowledge Base for further details.


IIS Assessment
The HTTP error messages typically indicate a problem with the configuration of the Internet Information Services (IIS). To diagnose the problem, check the IIS logs for the full error code. The default location for the logs is:
C:\Windows\System32\LogFiles\W3SVC1

Note: Please have this log ready for technicians when contacting Technical Support.



Ensure that the appropriate rights are configured for IIS.



Java Assessment
For more information on Java, see the following document:

"Symantec Endpoint Protection Manager remote console is not able to login using Java version 1.6." at:
http://service1.symantec.com/SUPPORT/ent-security.nsf/docid/2007082014541748


The default heap size for the Symantec Endpoint Protection Manager is 256MB. Be sure to adjust the heap size as appropriate for the operating system. Please refer to page 89 of the installation_guide.pdf located on the installation CD or at the following FTP location:
ftp://ftp.symantec.com/public/english_us_canada/products/symantec_endpoint_protection/11.0/manuals/installation_guide.pdf


To adjust the Symantec Endpoint Protection Manager heap size:
  1. Click Start> Run.
  2. Type regedit
  3. Press Enter.
  4. Locate the following registry key:
    HKLM\SYSTEM\CurrentControlSet\Services\semsrv\Parameters\

  5. Locate the following keys:
    JVM Option Number 0
    JVM Option Number 1


  6. Adjust the key values upward, and match the key values.
    For example, to create a 1 GB static heap, set the JVM Option Number 0 to -Xms1024m, and set the JVM Option Number 1 to -Xmx1024m.
  7. Exit Regedit.
  8. Click Start> Settings> Control Panel> Administrative Tools.
  9. In the Services dialog box, right-click Symantec Endpoint Protection Manager, and then click Restart.



PHP Assessment
Running multiple versions of PHP being used by different software products may cause conflicts. PHP performs a check for global configuration (php.ini) in a variety of locations. It forces each product to use its own interpreter which allows the product to operate properly and to use the correct version of PHP associated with each product. Please check your PHP configuration.


Database Assessment
References:
"Troubleshooting Client/Server Connectivity." at:
http://service1.symantec.com/SUPPORT/ent-security.nsf/docid/2008091215040048


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Document ID: 2007101711103548
Last Modified: 10/21/2008
Date Created: 10/17/2007
Operating System(s): Windows 2000 Professional, Windows XP Professional Edition, Windows Server 2003 Web/Standard/Enterprise/Datacenter Edition
Product(s): Endpoint Protection 11
Release(s): Endpoint Protection 11 [All Releases], Endpoint Protection 11.0


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