Question/Issue:
You notice that the Symantec Premium AntiSpam Add-on for Microsoft Exchange is not catching large amounts of mail that are clearly spam or other. When checking the BM_Rulesets, you suspect that they may be corrupt.
Symptoms:
Large amounts of seemingly obvious spam is being missed by the Symantec Premium AntiSpam (SPA) Add-on. When viewing the Server folder, you notice that there are a larger than average number of BM_Rulesets folders.
A less common symptom would also be a lag in SPA updates. SPA should update every 10-15 minutes, on average.
Cause:
Corrupted rulesets in the Symantec Mail Security for Microsoft Exchange Server folder.
Solution:
Manually replace the BM_Rulesets for Premium AntiSpam in Windows 2000/2003 environment:
1. Stop the service: Symantec Mail Security for Microsoft Exchange
2. Stop one of the following services:
a. Symantec Mail Security Spam Statistics (SMSMSE 5.0.x)
b. Symantec Mail Security Utility Service (SIFMSMSE >6.0.x)
3. Browse to the location where your rulesets are found:
The default location is either:
a. For x86 (usually Exchange 2003 or earlier): <sys vol>:\Program Files\Symantec\SMSMSE\<version>\Server
b. For a 64-bit machine (usually Exchange 2007 or later): <sys vol>:\Program Files(x86)\Symantec\SMSMSE\<version>\Server
4. Delete all BM_Rulesets folders.
5. Delete the following files: .sequence.0, .sequence.2, blrm, hashes
(Note: In the 6.0.8.x installed version of SMSMSE the .sequence.0, blrm do not exist.)
6. Restart IIS from the IIS Console:
a. Open the Internet Information Services ( Start > Programs > Administrative Tools > Internet Information Services (IIS) Manager)
b. Right-click on the name of your server and go to All Tasks > Restart IIS
Note: This generally only takes about 2-5 minutes, depending on the machine.
Warning: This will reset anyone logged into OWA and will reset websites hosted from this machine through this IIS.
7. Start the Symantec Mail Security for Microsoft Exchange service.
Note: You do not need to start the Spam Statistics or Utility Service (from Step 2), these are automatic
Technical Information:
Other Documents related to this issue:
Title: 'Testing mail flow and spam detection for Symantec products with AntiSpam'
Document ID: 2005041106461554
> Web URL: http://service1.symantec.com/SUPPORT/ent-gate.nsf/docid/2005041106461554?Open&seg=ent
Title: 'Premium AntiSpam for Symantec Mail Security for Microsoft Exchange fails to detect spam'
Document ID: 2007020615531854
> Web URL: http://service1.symantec.com/SUPPORT/ent-gate.nsf/docid/2007020615531854?Open&seg=ent
Document ID: 2006011716254054
Last Modified: 04/22/2009
Date Created: 01/17/2006
Operating System(s): Windows 2000 Server SP4, Windows 2000 Advanced Server SP4, Windows Server 2003 Standard SP1, Windows Server 2003 Advanced SP1, Windows 2000 Server/Advanced Server/Data Center SP4, Windows Server 2003 Standard/Enterprise/Data Center (no SP required), Exchange 2000 Server SP3/Enterprise Server, Exchange Server 2003/Enterprise Server
Product(s): Symantec Mail Security 4.6 for Microsoft Exchange, Symantec Mail Security 5.x for Microsoft Exchange, Symantec Mail Security 6.0 for Microsoft Exchange
Release(s): MSME 5.0 [All Releases], SMS 4.6 [All Releases], SMSMSE 6.0 [All Releases]